<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<!--[if IE 8]>
<html id="ie8" xmlns="http://www.w3.org/1999/xhtml" lang="en">
<![endif]-->
<!--[if !(IE 8)]><!-->
<html xmlns="http://www.w3.org/1999/xhtml" lang="en">
<!--<![endif]-->
<head profile="http://gmpg.org/xfn/11">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<title>Droppin&#8217; Bombs with M.O.M. | The Greatest Movie EVER! Podcast</title>
<link rel="pingback" href="https://gmepodcast.com/xmlrpc.php" />
		<script src='https://r-login.wordpress.com/remote-login.php?action=js&amp;host=gmepodcast.com&amp;id=736319&amp;t=1494233365&amp;back=https%3A%2F%2Fgmepodcast.com%2F2017%2F05%2F07%2Fdroppin-bombs-with-m-o-m%2F' type="text/javascript"></script>
		<script type="text/javascript">
		/* <![CDATA[ */
			if ( 'function' === typeof WPRemoteLogin ) {
				document.cookie = "wordpress_test_cookie=test; path=/";
				if ( document.cookie.match( /(;|^)\s*wordpress_test_cookie\=/ ) ) {
					WPRemoteLogin();
				}
			}
		/* ]]> */
		</script>
		<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//gooberzilla.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="The Greatest Movie EVER! Podcast &raquo; Feed" href="https://gmepodcast.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Greatest Movie EVER! Podcast &raquo; Comments Feed" href="https://gmepodcast.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Greatest Movie EVER! Podcast &raquo; Droppin&#8217; Bombs with&nbsp;M.O.M. Comments Feed" href="https://gmepodcast.com/2017/05/07/droppin-bombs-with-m-o-m/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s1.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1488818651h&ver=4.7.4"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='all-css-0-1' href='https://s0.wp.com/_static/??-eJyNkd1OwzAMhV+IEI1VAy4Qz5IfN/PmxFHiMvr2pFTA6FDETeQTnS8+sfUlK8dJIImOk8o0BUxVX7LjqGpEgnmj7l2td/pvjPAMVZ9AsnFn9alu7JY4/PTh4o2vOhBbQ//zegxhr94eekEKkBHwKnOVjephmEZMKLOWI8T2kzzZtV0Pclyg3cdsZHFE8GiAGp+kh8V8+KKW8tgm1s22LsHaXKBW1c6IU1Rr0Btum19XmQm6z6MP0GY1GgeWed2e5fdrEnViwQbX76L3ZABWxM4Icvol1EgGS39/y+pbGXRzXckFeo0vu+HpcX/YDc/D6QNPngjz' type='text/css' media='all' />
<link rel='stylesheet' id='print-css-1-1' href='https://s0.wp.com/wp-content/mu-plugins/global-print/global-print.css?m=1465851035h' type='text/css' media='print' />
<link rel='stylesheet' id='all-css-2-1' href='https://s2.wp.com/_static/??-eJx9i9EKwjAMRX/IGoVN54P4LVnp2kialCbD3xcfRGTi0z0XzoFHC1HFkzjUNTReM4kBRieVGfuH9tFsB7/1puZhYaQOVrCT5Pf+q0wjIQfWrN9nE3lJNRmUATLrjPwSbvV6HC6H83Qap/H+BMWZScE=' type='text/css' media='all' />
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJyFj9EKwjAMRX/IrE4m7kX8ltnFktqmtWkd+vV2oA/qUAiE3JxcbtQUgVi7MqIoW+tSMN2erbGyUr8A8GTSkLHxxC9YB87IeWZ9OJJDKIJpMFWrRqewwMUg2aNIhRa275GIr4TTX8xijoM+Q0Kh+5erLxBdMcSiErr6wAhzho+pXh38vu363aZvt93aPgArrnBz'></script>
<link rel='stylesheet' id='all-css-0-2' href='https://s1.wp.com/wp-content/mu-plugins/highlander-comments/style.css?m=1377793621h' type='text/css' media='all' />
<!--[if lt IE 8]>
<link rel='stylesheet' id='highlander-comments-ie7-css'  href='https://s1.wp.com/wp-content/mu-plugins/highlander-comments/style-ie7.css?m=1351637563h&#038;ver=20110606' type='text/css' media='all' />
<![endif]-->
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://gooberzilla.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='&#8220;Let me know if you see a Radio&nbsp;Shack.&#8221;' href='https://gmepodcast.com/2017/04/23/let-me-know-if-you-see-a-radio-shack/' />
<meta name="generator" content="WordPress.com" />
<link rel="canonical" href="https://gmepodcast.com/2017/05/07/droppin-bombs-with-m-o-m/" />
<link rel='shortlink' href='http://wp.me/p35y7-Hd' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/1.0/?format=json&amp;url=https%3A%2F%2Fgmepodcast.com%2F2017%2F05%2F07%2Fdroppin-bombs-with-m-o-m%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/1.0/?format=xml&amp;url=https%3A%2F%2Fgmepodcast.com%2F2017%2F05%2F07%2Fdroppin-bombs-with-m-o-m%2F&amp;for=wpcom-auto-discovery" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Droppin&#8217; Bombs with M.O.M." />
<meta property="og:url" content="https://gmepodcast.com/2017/05/07/droppin-bombs-with-m-o-m/" />
<meta property="og:description" content="Strap on your fur loincloth, because The Barbarians (1987) is the Greatest Movie EVER! Click on the title or the DVD cover above to download our review of the film, featuring M.O.M., the Mistress o…" />
<meta property="article:published_time" content="2017-05-07T11:39:25+00:00" />
<meta property="article:modified_time" content="2017-05-07T11:39:25+00:00" />
<meta property="og:site_name" content="The Greatest Movie EVER! Podcast" />
<meta property="og:image" content="https://gooberzilla.files.wordpress.com/2017/05/barbarians_thenorsemen.jpg" />
<meta property="og:image:secure_url" content="https://gooberzilla.files.wordpress.com/2017/05/barbarians_thenorsemen.jpg" />
<meta property="og:image:width" content="360" />
<meta property="og:image:height" content="510" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@wordpressdotcom" />
<meta name="twitter:image" content="https://gooberzilla.files.wordpress.com/2017/05/barbarians_thenorsemen.jpg?w=1400" />
<meta name="twitter:card" content="photo" />
<meta property="article:publisher" content="https://www.facebook.com/WordPresscom" />
<link rel="shortcut icon" type="image/x-icon" href="https://secure.gravatar.com/blavatar/b540782203e9bb277d4207695c34f1f1?s=32" sizes="16x16" />
<link rel="icon" type="image/x-icon" href="https://secure.gravatar.com/blavatar/b540782203e9bb277d4207695c34f1f1?s=32" sizes="16x16" />
<link rel="apple-touch-icon-precomposed" href="https://secure.gravatar.com/blavatar/b540782203e9bb277d4207695c34f1f1?s=114" />
<link rel='openid.server' href='https://gooberzilla.wordpress.com/?openidserver=1' />
<link rel='openid.delegate' href='https://gooberzilla.wordpress.com/' />
<link rel="search" type="application/opensearchdescription+xml" href="https://gmepodcast.com/osd.xml" title="The Greatest Movie EVER! Podcast" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />
		<style id="wpcom-hotfix-masterbar-style">
			@media screen and (min-width: 783px) {
				#wpadminbar .quicklinks li#wp-admin-bar-my-account.with-avatar > a img {
					margin-top: 5px;
				}
			}
		</style>
		<meta name="application-name" content="The Greatest Movie EVER! Podcast" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-tooltip" content="Reviewing only the finest films in the history of cinema.  And robots, too." /><meta name="msapplication-task" content="name=Subscribe;action-uri=https://gmepodcast.com/feed/;icon-uri=https://secure.gravatar.com/blavatar/b540782203e9bb277d4207695c34f1f1?s=16" /><meta name="msapplication-task" content="name=Sign up for a free blog;action-uri=http://wordpress.com/signup/;icon-uri=https://s2.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Support;action-uri=http://support.wordpress.com/;icon-uri=https://s2.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Forums;action-uri=http://forums.wordpress.com/;icon-uri=https://s2.wp.com/i/favicon.ico" /><meta name="title" content="Droppin&#8217; Bombs with&nbsp;M.O.M. | The Greatest Movie EVER! Podcast on WordPress.com" />
<meta name="description" content="Strap on your fur loincloth, because The Barbarians (1987) is the Greatest Movie EVER! Click on the title or the DVD cover above to download our review of the film, featuring M.O.M., the Mistress of Malapropisms. Review in a Nutshell: A thoroughly generic Conan the Barbarian rip-off buoyed up by its scattershot production design and&hellip;" />
<style type="text/css">
#header h1 a, #header h1 a:hover, #header .description {
color: #ffffff;
}
</style>
 		<script type="text/javascript">
		var _ipw_custom = {
				wordAds: '0',
				adSafe: '1',
				domain: 'gmepodcast.com',
				pageURL: 'https://gmepodcast.com/2017/05/07/droppin-bombs-with-m-o-m/'
			};
		</script>
		<script type="text/javascript" src="//c.amazon-adsystem.com/aax2/amzn_ads.js"></script>
 		<script type="text/javascript" src="//s.pubmine.com/head.js"></script>
		<script type="text/javascript" src="https://static.criteo.net/js/ld/publishertag.js"></script><link rel="amphtml" href="https://gmepodcast.com/2017/05/07/droppin-bombs-with-m-o-m/amp/" /><style type="text/css" id="syntaxhighlighteranchor"></style>
<script type="text/javascript">
	window.google_analytics_uacct = "UA-52447-2";
</script>

<script type="text/javascript">
	var _gaq = _gaq || [];
	_gaq.push(['_setAccount', 'UA-52447-2']);
	_gaq.push(['_setDomainName', 'none']);
	_gaq.push(['_setAllowLinker', true]);
	_gaq.push(['_initData']);
	_gaq.push(['_trackPageview']);

	(function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		(document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(ga);
	})();
</script>
</head>
<body class="post-template-default single single-post postid-2679 single-format-standard mp6 customizer-styles-applied highlander-enabled highlander-light"><div id="container">

<div id="header">

	<div id="menu">
		<ul class="menu">
	<li class="page_item"><a href="https://gmepodcast.com/">Home</a></li>
	<li class="page_item page-item-2119"><a href="https://gmepodcast.com/anime-fun-time/">Anime Fun Time</a></li>
<li class="page_item page-item-441"><a href="https://gmepodcast.com/archives-f/">Archives # &#8211;&nbsp;F</a></li>
<li class="page_item page-item-444"><a href="https://gmepodcast.com/archives-g-l/">Archives G &#8211;&nbsp;L</a></li>
<li class="page_item page-item-449"><a href="https://gmepodcast.com/archives-m-r/">Archives M &#8211;&nbsp;R</a></li>
<li class="page_item page-item-452"><a href="https://gmepodcast.com/archives-s-z/">Archives S &#8211;&nbsp;Z</a></li>
</ul>
	</div>

	<div id="header-box">
	<div id="header-image">
		<img src="https://gooberzilla.wordpress.com/wp-content/themes/pub/digg3/images/bg_header_img.png?m=1391151072h" alt="" />
	</div>
	<div id="header-overlay">
		<img src="https://s0.wp.com/wp-content/themes/pub/digg3/images/bg_header_overlay.png" alt="" />
	</div>

	<div id="pagetitle">
		<h1><a href="https://gmepodcast.com/" title="The Greatest Movie EVER! Podcast">The Greatest Movie EVER! Podcast</a></h1>
	</div>

	<div id="syndication">
		<a href="https://gmepodcast.com/feed/" title="Syndicate this site using RSS" class="feed">Entries <abbr title="Really Simple Syndication">RSS</abbr></a> &#124; <a href="https://gmepodcast.com/comments/feed/" title="Syndicate comments using RSS">Comments RSS</a>
	</div>
	<div id="searchbox">
		<form method="get" id="searchform" action="https://gmepodcast.com/">
<div>
	<input type="text" value="" name="s" id="s" />
	<input type="submit" id="searchsubmit" value="Search" />
</div>
</form>	</div>
	</div>
</div>

<div class="pagewrapper"><div id="page">

<!-- Start Obar -->

	<div class="obar">
<ul>

<li id="rss-1" class="widget widget_rss"><h2 class="widgettitle"><a class="rsswidget" href="http://gooberzilla.libsyn.com/rss/" title="Syndicate this content"><img style="background: orange; color: white; border: none;" width="14" height="14" src="https://s-ssl.wordpress.com/wp-includes/images/rss.png?m=1354137473h" alt="RSS" /></a> <a class="rsswidget" href="https://gmepodcast.com/" title="A podcast dedicated to reviewing only the Greatest Movies EVER!">Click this orange button to subscribe to our RSS feed.</a></h2>
<ul><li><a class='rsswidget' href='https://gmepodcast.com/2017/05/07/droppin-bombs-with-m-o-m' title='In this episode, Mom and I review The Barbarians (1987) -- quite possibly the Greatest Movie EVER!'>The Barbarians (1987) Podcast</a></li><li><a class='rsswidget' href='https://gmepodcast.com/2017/04/23/let-me-know-if-you-see-a-radio-shack' title='In this episode, Sean and I review Kung Pow! Enter the Fist -- quite possibly the Greatest Movie EVER!'>The Kung Pow! Enter the Fist Podcast</a></li><li><a class='rsswidget' href='https://gmepodcast.com/2017/04/02/gme-anime-fun-time-26-bikini-warriors' title='Tom and I take a look at the 2015 cheesecake fantasy TV anime, Bikini Warriors, and ponder how a show so short can feel so long.'>GME! Anime Fun Time - Bikini Warriors</a></li></ul></li>
<li id="text-1" class="widget widget_text"><h2 class="widgettitle">Contact Us</h2>
			<div class="textwidget"><P><A HREF="mailto:gooberzilla@aol.com">E-mail us!</A></P></div>
		</li>
<li id="facebook-likebox-3" class="widget widget_facebook_likebox">		<div id="fb-root"></div>
		<div class="fb-page" data-href="https://www.facebook.com/pages/The-Greatest-Movie-EVER-Podcast/359555357023" data-width="200"  data-height="432" data-hide-cover="false" data-show-facepile="true" data-show-posts="false">
		<div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/pages/The-Greatest-Movie-EVER-Podcast/359555357023"><a href="https://www.facebook.com/pages/The-Greatest-Movie-EVER-Podcast/359555357023"></a></blockquote></div>
		</div>
		</li>
<li id="blog_subscription-3" class="widget widget_blog_subscription"><h2 class="widgettitle"><label for="subscribe-field">Follow Blog via Email</label></h2>

				<form action="https://subscribe.wordpress.com" method="post" accept-charset="utf-8" id="subscribe-blog">
											<p>Enter your email address to follow this blog and receive notifications of new posts by email.</p>
<p>Join 288 other followers</p>
						<p><input type="text" name="email" style="width: 95%; padding: 1px 2px" placeholder="Enter your email address" value="" id="subscribe-field"/></p>
					
					<p>
						<input type="hidden" name="action" value="subscribe"/>
						<input type="hidden" name="blog_id" value="736319"/>
						<input type="hidden" name="source" value="https://gmepodcast.com/2017/05/07/droppin-bombs-with-m-o-m/"/>
						<input type="hidden" name="sub-type" value="widget"/>
						<input type="hidden" name="redirect_fragment" value="blog_subscription-3" />
						<input type="hidden" id="_wpnonce" name="_wpnonce" value="e6db22e23a" />						<input type="submit" value="Follow" />
					</p>
				</form>
			
</li>

</ul>
	</div>

<!-- End Obar -->
	<div class="wrapper"><!-- This wrapper class appears only on Page and Single Post pages. -->
	<div class="narrowcolumnwrapper"><div class="narrowcolumn">

		<div class="content">

			
			<div class="post-2679 post type-post status-publish format-standard hentry category-dragons category-fantasy category-greatest-movie-ever category-werewolves tag-barbarians tag-cannon-film-group tag-david-paul tag-fantasy-films tag-menahem-golan tag-peter-paul tag-richard-lynch tag-ruggero-deodato tag-sword-and-sandals tag-sword-and-sorcery tag-yoram-globus" id="post-2679">

				<h2><a href="https://gmepodcast.com/2017/05/07/droppin-bombs-with-m-o-m/" rel="bookmark" title="Droppin&#8217; Bombs with&nbsp;M.O.M.">Droppin&#8217; Bombs with&nbsp;M.O.M.</a></h2>

				<div class="postinfo">
					Posted on <span class="postdate">May 7, 2017</span> by gooberzilla									</div>

				<div class="entry">

					<p><a href="http://traffic.libsyn.com/gooberzilla/the_barbarians050717.mp3"><img data-attachment-id="2680" data-permalink="https://gmepodcast.com/2017/05/07/droppin-bombs-with-m-o-m/barbarians_thenorsemen/" data-orig-file="https://gooberzilla.files.wordpress.com/2017/05/barbarians_thenorsemen.jpg?w=468" data-orig-size="360,510" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="barbarians_thenorsemen" data-image-description="" data-medium-file="https://gooberzilla.files.wordpress.com/2017/05/barbarians_thenorsemen.jpg?w=468?w=212" data-large-file="https://gooberzilla.files.wordpress.com/2017/05/barbarians_thenorsemen.jpg?w=468?w=360" class="aligncenter size-full wp-image-2680" src="https://gooberzilla.files.wordpress.com/2017/05/barbarians_thenorsemen.jpg?w=468" alt="" srcset="https://gooberzilla.files.wordpress.com/2017/05/barbarians_thenorsemen.jpg 360w, https://gooberzilla.files.wordpress.com/2017/05/barbarians_thenorsemen.jpg?w=106 106w, https://gooberzilla.files.wordpress.com/2017/05/barbarians_thenorsemen.jpg?w=212 212w" sizes="(max-width: 360px) 100vw, 360px"   /></a></p>
<p style="text-align:center;">Strap on your fur loincloth, because <a href="http://traffic.libsyn.com/gooberzilla/the_barbarians050717.mp3">The Barbarians (1987)</a> is the Greatest Movie EVER!</p>
<p style="text-align:center;">Click on the title or the DVD cover above to download our review of the film, featuring M.O.M., the Mistress of Malapropisms.</p>
<p><em>Review in a Nutshell</em>: A thoroughly generic <em>Conan the Barbarian</em> rip-off buoyed up by its scattershot production design and the exuberant performances of Peter and David Paul (aka the Barbarian Brothers), <em>The Barbarians</em> (1987) is everything I&#8217;ve ever wanted in a Cannon Film Group film directed by Ruggero Deodato.</p>
		<div class="wpcnt">
			<div class="wpa wpmrec">
				<span class="wpa-about">Advertisements</span>
				<div class="u">
								<script type='text/javascript'>
				(function(g){if("undefined"!=typeof g.__ATA){g.__ATA.initAd({sectionId:26942, width:300, height:250});}})(window);
			</script>
				</div>
				        <div id="crt-130124943" style="width:300px;height:250px;"></div>
        <script type="text/javascript">
        var o = document.getElementById('crt-130124943');
        if ("undefined"!=typeof Criteo) {
            var p = o.parentNode;
            p.style.setProperty('display', 'inline-block', 'important');
            o.style.setProperty('display', 'block', 'important');
            Criteo.DisplayAcceptableAdIfAdblocked({zoneid:388248,containerid:"crt-130124943",collapseContainerIfNotAdblocked:true,"callifnotadblocked": function () {var o = document.getElementById('crt-130124943'); o.style.setProperty('display','none','important');o.style.setProperty('visbility','hidden','important'); }
        });
        } else {
            o.style.setProperty('display', 'none', 'important');
            o.style.setProperty('visibility', 'hidden', 'important');
        }
        </script>
			</div>
		</div><div id="jp-post-flair" class="sharedaddy sd-like-enabled sd-sharing-enabled"><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li><a href="#" class="sharing-anchor sd-button share-more"><span>Share</span></a></li><li class="share-end"></li></ul><div class="sharing-hidden"><div class="inner" style="display: none;"><ul><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-2679" class="share-facebook sd-button share-icon" href="https://gmepodcast.com/2017/05/07/droppin-bombs-with-m-o-m/?share=facebook" target="_blank" title="Share on Facebook"><span>Facebook</span></a></li><li class="share-linkedin"><a rel="nofollow" data-shared="sharing-linkedin-2679" class="share-linkedin sd-button share-icon" href="https://gmepodcast.com/2017/05/07/droppin-bombs-with-m-o-m/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-end"></li><li class="share-reddit"><a rel="nofollow" data-shared="" class="share-reddit sd-button share-icon" href="https://gmepodcast.com/2017/05/07/droppin-bombs-with-m-o-m/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-2679" class="share-twitter sd-button share-icon" href="https://gmepodcast.com/2017/05/07/droppin-bombs-with-m-o-m/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-end"></li><li class="share-end"></li></ul></div></div></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-736319-2679-591031159df8c' data-src='//widgets.wp.com/likes/#blog_id=736319&amp;post_id=2679&amp;origin=gooberzilla.wordpress.com&amp;obj_id=736319-2679-591031159df8c' data-name='like-post-frame-736319-2679-591031159df8c'><h3 class='sd-title'>Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div></div>					
					<p class="postinfo">
						Filed under: <a href="https://gmepodcast.com/category/dragons/" rel="category tag">Dragons</a>, <a href="https://gmepodcast.com/category/fantasy/" rel="category tag">Fantasy</a>, <a href="https://gmepodcast.com/category/greatest-movie-ever/" rel="category tag">Greatest Movie EVER</a>, <a href="https://gmepodcast.com/category/werewolves/" rel="category tag">Werewolves</a> &#124; Tagged: <a href="https://gmepodcast.com/tag/barbarians/" rel="tag">Barbarians</a>, <a href="https://gmepodcast.com/tag/cannon-film-group/" rel="tag">Cannon Film Group</a>, <a href="https://gmepodcast.com/tag/david-paul/" rel="tag">David Paul</a>, <a href="https://gmepodcast.com/tag/fantasy-films/" rel="tag">Fantasy Films</a>, <a href="https://gmepodcast.com/tag/menahem-golan/" rel="tag">Menahem Golan</a>, <a href="https://gmepodcast.com/tag/peter-paul/" rel="tag">Peter Paul</a>, <a href="https://gmepodcast.com/tag/richard-lynch/" rel="tag">Richard Lynch</a>, <a href="https://gmepodcast.com/tag/ruggero-deodato/" rel="tag">Ruggero Deodato</a>, <a href="https://gmepodcast.com/tag/sword-and-sandals/" rel="tag">Sword and Sandals</a>, <a href="https://gmepodcast.com/tag/sword-and-sorcery/" rel="tag">Sword and Sorcery</a>, <a href="https://gmepodcast.com/tag/yoram-globus/" rel="tag">Yoram Globus</a> &#124;					</p>

				</div>
			</div>



			<div class="browse">&laquo; <a href="https://gmepodcast.com/2017/04/23/let-me-know-if-you-see-a-radio-shack/" rel="prev">&#8220;Let me know if you see a Radio&nbsp;Shack.&#8221;</a> </div>



		</div><!-- End content -->

	</div></div><!-- End narrowcolumnwrapper and narrowcolumn classes -->

	
<div class="narrowcolumnwrapper"><div class="narrowcolumn">
	<div class="content">
	<div class="post post-2679 type-post status-publish format-standard hentry category-dragons category-fantasy category-greatest-movie-ever category-werewolves tag-barbarians tag-cannon-film-group tag-david-paul tag-fantasy-films tag-menahem-golan tag-peter-paul tag-richard-lynch tag-ruggero-deodato tag-sword-and-sandals tag-sword-and-sorcery tag-yoram-globus">




	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/05/07/droppin-bombs-with-m-o-m/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://gmepodcast.com/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<input type="hidden" id="highlander_comment_nonce" name="highlander_comment_nonce" value="e2265a5d70" /><input type="hidden" name="_wp_http_referer" value="/2017/05/07/droppin-bombs-with-m-o-m/" />
<input type="hidden" name="hc_post_as" id="hc_post_as" value="guest" />

<div class="comment-form-field comment-textarea">
	<label for="comment">Enter your comment here...</label>
	<div id="comment-form-comment"><textarea id="comment" name="comment" title="Enter your comment here..."></textarea></div>
</div>

<div id="comment-form-identity">

	<div id="comment-form-nascar">
		<p>Fill in your details below or click an icon to log in:</p>
		<ul>
			<li class="selected" style="display:none;">
				<a href="#comment-form-guest" id="postas-guest" title="Guest">
					<span></span>
				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:WordPress.com" id="postas-wordpress" title="WordPress.com">
					<span></span>
				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:Twitter" id="postas-twitter" title="Twitter">
					<span></span>
				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:Facebook" id="postas-facebook" title="Facebook">
					<span></span>
				</a>
			</li>
			<li>
		</ul>
	</div>

	<div id="comment-form-guest" class="comment-form-service selected">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
<a href="https://gravatar.com/site/signup/" target="_blank">				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y" alt="Gravatar" width="25" class="no-grav" />
</a>			</div>

				<div class="comment-form-fields">
				<div class="comment-form-field comment-form-email">
					<label for="email">Email <span class="required">(required)</span> <span class="nopublish">(Address never made public)</span></label>
					<div class="comment-form-input"><input id="email" name="email" type="email" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-author">
					<label for="author">Name <span class="required">(required)</span></label>
					<div class="comment-form-input"><input id="author" name="author" type="text" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-url">
					<label for="url">Website</label>
					<div class="comment-form-input"><input id="url" name="url" type="url" value="" /></div>
				</div>
			</div>
	
		</div>
	</div>

	<div id="comment-form-wordpress" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y" alt="WordPress.com Logo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="wp_avatar" id="wordpress-avatar" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_user_id" id="wordpress-user_id" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_access_token" id="wordpress-access_token" class="comment-meta-wordpress" value="" />
				<p class="comment-form-posting-as pa-wordpress"><strong></strong> You are commenting using your WordPress.com account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'wordpress' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>

	<div id="comment-form-twitter" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y" alt="Twitter picture" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="twitter_avatar" id="twitter-avatar" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_user_id" id="twitter-user_id" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_access_token" id="twitter-access_token" class="comment-meta-twitter" value="" />
				<p class="comment-form-posting-as pa-twitter"><strong></strong> You are commenting using your Twitter account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'twitter' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>

	<div id="comment-form-facebook" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y" alt="Facebook photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="fb_avatar" id="facebook-avatar" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_user_id" id="facebook-user_id" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_access_token" id="facebook-access_token" class="comment-meta-facebook" value="" />
				<p class="comment-form-posting-as pa-facebook"><strong></strong> You are commenting using your Facebook account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'facebook' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>

	<div id="comment-form-googleplus" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y" alt="Google+ photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="googleplus_avatar" id="googleplus-avatar" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_user_id" id="googleplus-user_id" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_access_token" id="googleplus-access_token" class="comment-meta-googleplus" value="" />
				<p class="comment-form-posting-as pa-googleplus"><strong></strong> You are commenting using your Google+ account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'googleplus' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>


	<div id="comment-form-load-service" class="comment-form-service">
		<div class="comment-form-posting-as-cancel"><a href="javascript:HighlanderComments.cancelExternalWindow();">Cancel</a></div>
		<p>Connecting to %s</p>
	</div>

</div>

<script type="text/javascript">
var highlander_expando_javascript = function(){
	var input = document.createElement( 'input' ),
	    comment = jQuery( '#comment' );

	if ( 'placeholder' in input ) {
		comment.attr( 'placeholder', jQuery( '.comment-textarea label' ).remove().text() );
	}

	// Expando Mode: start small, then auto-resize on first click + text length
	jQuery( '#comment-form-identity' ).hide();
	jQuery( '#comment-form-subscribe' ).hide();
	jQuery( '#commentform .form-submit' ).hide();

	comment.css( { 'height':'10px' } ).one( 'focus', function() {
		var timer = setInterval( HighlanderComments.resizeCallback, 10 )
		jQuery( this ).animate( { 'height': HighlanderComments.initialHeight } ).delay( 100 ).queue( function(n) { clearInterval( timer ); HighlanderComments.resizeCallback(); n(); } );
		jQuery( '#comment-form-identity' ).slideDown();
		jQuery( '#comment-form-subscribe' ).slideDown();
		jQuery( '#commentform .form-submit' ).slideDown();
	});
}
jQuery(document).ready( highlander_expando_javascript );
</script>

<div id="comment-form-subscribe">
	<p class="comment-subscription-form"><input type="checkbox" name="subscribe" id="subscribe" value="subscribe" style="width: auto;"/> <label class="subscribe-label" id="subscribe-label" for="subscribe" style="display: inline;">Notify me of new comments via email.</label></p><p class="post-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto;"/> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog"  style="display: inline;">Notify me of new posts via email.</label></p></div>




<p class="form-submit"><input name="submit" type="submit" id="comment-submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='2679' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="e2c7d7d3ce" /></p>
<input type="hidden" name="genseq" value="1494233365" />
<p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="45"/></p>			</form>
			</div><!-- #respond -->
	<div style="clear: both"></div>
	</div>
	</div>
</div></div>


	</div><!-- End wrapper class -->

	<div class="sidebar">
	<ul>

<li id="archives-2" class="widget widget_archive"><h2 class="widgettitle">Archives</h2>
		<label class="screen-reader-text" for="archives-dropdown-2">Archives</label>
		<select id="archives-dropdown-2" name="archive-dropdown" onchange='document.location.href=this.options[this.selectedIndex].value;'>
			
			<option value="">Select Month</option>
				<option value='https://gmepodcast.com/2017/05/'> May 2017 </option>
	<option value='https://gmepodcast.com/2017/04/'> April 2017 </option>
	<option value='https://gmepodcast.com/2017/03/'> March 2017 </option>
	<option value='https://gmepodcast.com/2017/02/'> February 2017 </option>
	<option value='https://gmepodcast.com/2017/01/'> January 2017 </option>
	<option value='https://gmepodcast.com/2016/12/'> December 2016 </option>
	<option value='https://gmepodcast.com/2016/11/'> November 2016 </option>
	<option value='https://gmepodcast.com/2016/10/'> October 2016 </option>
	<option value='https://gmepodcast.com/2016/09/'> September 2016 </option>
	<option value='https://gmepodcast.com/2016/08/'> August 2016 </option>
	<option value='https://gmepodcast.com/2016/07/'> July 2016 </option>
	<option value='https://gmepodcast.com/2016/06/'> June 2016 </option>
	<option value='https://gmepodcast.com/2016/05/'> May 2016 </option>
	<option value='https://gmepodcast.com/2016/04/'> April 2016 </option>
	<option value='https://gmepodcast.com/2016/03/'> March 2016 </option>
	<option value='https://gmepodcast.com/2016/02/'> February 2016 </option>
	<option value='https://gmepodcast.com/2016/01/'> January 2016 </option>
	<option value='https://gmepodcast.com/2015/12/'> December 2015 </option>
	<option value='https://gmepodcast.com/2015/11/'> November 2015 </option>
	<option value='https://gmepodcast.com/2015/10/'> October 2015 </option>
	<option value='https://gmepodcast.com/2015/09/'> September 2015 </option>
	<option value='https://gmepodcast.com/2015/08/'> August 2015 </option>
	<option value='https://gmepodcast.com/2015/07/'> July 2015 </option>
	<option value='https://gmepodcast.com/2015/06/'> June 2015 </option>
	<option value='https://gmepodcast.com/2015/05/'> May 2015 </option>
	<option value='https://gmepodcast.com/2015/04/'> April 2015 </option>
	<option value='https://gmepodcast.com/2015/03/'> March 2015 </option>
	<option value='https://gmepodcast.com/2015/02/'> February 2015 </option>
	<option value='https://gmepodcast.com/2015/01/'> January 2015 </option>
	<option value='https://gmepodcast.com/2014/12/'> December 2014 </option>
	<option value='https://gmepodcast.com/2014/11/'> November 2014 </option>
	<option value='https://gmepodcast.com/2014/10/'> October 2014 </option>
	<option value='https://gmepodcast.com/2014/09/'> September 2014 </option>
	<option value='https://gmepodcast.com/2014/08/'> August 2014 </option>
	<option value='https://gmepodcast.com/2014/07/'> July 2014 </option>
	<option value='https://gmepodcast.com/2014/06/'> June 2014 </option>
	<option value='https://gmepodcast.com/2014/05/'> May 2014 </option>
	<option value='https://gmepodcast.com/2014/04/'> April 2014 </option>
	<option value='https://gmepodcast.com/2014/03/'> March 2014 </option>
	<option value='https://gmepodcast.com/2014/02/'> February 2014 </option>
	<option value='https://gmepodcast.com/2014/01/'> January 2014 </option>
	<option value='https://gmepodcast.com/2013/12/'> December 2013 </option>
	<option value='https://gmepodcast.com/2013/11/'> November 2013 </option>
	<option value='https://gmepodcast.com/2013/10/'> October 2013 </option>
	<option value='https://gmepodcast.com/2013/09/'> September 2013 </option>
	<option value='https://gmepodcast.com/2013/08/'> August 2013 </option>
	<option value='https://gmepodcast.com/2013/07/'> July 2013 </option>
	<option value='https://gmepodcast.com/2013/06/'> June 2013 </option>
	<option value='https://gmepodcast.com/2013/05/'> May 2013 </option>
	<option value='https://gmepodcast.com/2013/04/'> April 2013 </option>
	<option value='https://gmepodcast.com/2013/03/'> March 2013 </option>
	<option value='https://gmepodcast.com/2013/02/'> February 2013 </option>
	<option value='https://gmepodcast.com/2013/01/'> January 2013 </option>
	<option value='https://gmepodcast.com/2012/12/'> December 2012 </option>
	<option value='https://gmepodcast.com/2012/11/'> November 2012 </option>
	<option value='https://gmepodcast.com/2012/10/'> October 2012 </option>
	<option value='https://gmepodcast.com/2012/09/'> September 2012 </option>
	<option value='https://gmepodcast.com/2012/08/'> August 2012 </option>
	<option value='https://gmepodcast.com/2012/07/'> July 2012 </option>
	<option value='https://gmepodcast.com/2012/06/'> June 2012 </option>
	<option value='https://gmepodcast.com/2012/05/'> May 2012 </option>
	<option value='https://gmepodcast.com/2012/04/'> April 2012 </option>
	<option value='https://gmepodcast.com/2012/03/'> March 2012 </option>
	<option value='https://gmepodcast.com/2012/02/'> February 2012 </option>
	<option value='https://gmepodcast.com/2012/01/'> January 2012 </option>
	<option value='https://gmepodcast.com/2011/12/'> December 2011 </option>
	<option value='https://gmepodcast.com/2011/11/'> November 2011 </option>
	<option value='https://gmepodcast.com/2011/10/'> October 2011 </option>
	<option value='https://gmepodcast.com/2011/09/'> September 2011 </option>
	<option value='https://gmepodcast.com/2011/08/'> August 2011 </option>
	<option value='https://gmepodcast.com/2011/07/'> July 2011 </option>
	<option value='https://gmepodcast.com/2011/06/'> June 2011 </option>
	<option value='https://gmepodcast.com/2011/05/'> May 2011 </option>
	<option value='https://gmepodcast.com/2011/04/'> April 2011 </option>
	<option value='https://gmepodcast.com/2011/03/'> March 2011 </option>
	<option value='https://gmepodcast.com/2011/02/'> February 2011 </option>
	<option value='https://gmepodcast.com/2011/01/'> January 2011 </option>
	<option value='https://gmepodcast.com/2010/12/'> December 2010 </option>
	<option value='https://gmepodcast.com/2010/11/'> November 2010 </option>
	<option value='https://gmepodcast.com/2010/10/'> October 2010 </option>
	<option value='https://gmepodcast.com/2010/09/'> September 2010 </option>
	<option value='https://gmepodcast.com/2010/08/'> August 2010 </option>
	<option value='https://gmepodcast.com/2010/07/'> July 2010 </option>
	<option value='https://gmepodcast.com/2010/06/'> June 2010 </option>
	<option value='https://gmepodcast.com/2010/05/'> May 2010 </option>
	<option value='https://gmepodcast.com/2010/04/'> April 2010 </option>
	<option value='https://gmepodcast.com/2010/03/'> March 2010 </option>
	<option value='https://gmepodcast.com/2010/02/'> February 2010 </option>
	<option value='https://gmepodcast.com/2010/01/'> January 2010 </option>
	<option value='https://gmepodcast.com/2009/12/'> December 2009 </option>
	<option value='https://gmepodcast.com/2009/11/'> November 2009 </option>
	<option value='https://gmepodcast.com/2009/10/'> October 2009 </option>
	<option value='https://gmepodcast.com/2009/09/'> September 2009 </option>
	<option value='https://gmepodcast.com/2009/08/'> August 2009 </option>
	<option value='https://gmepodcast.com/2009/07/'> July 2009 </option>
	<option value='https://gmepodcast.com/2009/06/'> June 2009 </option>
	<option value='https://gmepodcast.com/2009/05/'> May 2009 </option>
	<option value='https://gmepodcast.com/2009/04/'> April 2009 </option>
	<option value='https://gmepodcast.com/2009/03/'> March 2009 </option>
	<option value='https://gmepodcast.com/2009/02/'> February 2009 </option>
	<option value='https://gmepodcast.com/2009/01/'> January 2009 </option>
	<option value='https://gmepodcast.com/2008/12/'> December 2008 </option>
	<option value='https://gmepodcast.com/2008/11/'> November 2008 </option>
	<option value='https://gmepodcast.com/2008/10/'> October 2008 </option>
	<option value='https://gmepodcast.com/2008/09/'> September 2008 </option>
	<option value='https://gmepodcast.com/2008/08/'> August 2008 </option>
	<option value='https://gmepodcast.com/2008/07/'> July 2008 </option>
	<option value='https://gmepodcast.com/2008/06/'> June 2008 </option>
	<option value='https://gmepodcast.com/2008/05/'> May 2008 </option>
	<option value='https://gmepodcast.com/2008/04/'> April 2008 </option>
	<option value='https://gmepodcast.com/2008/03/'> March 2008 </option>
	<option value='https://gmepodcast.com/2008/02/'> February 2008 </option>
	<option value='https://gmepodcast.com/2008/01/'> January 2008 </option>
	<option value='https://gmepodcast.com/2007/12/'> December 2007 </option>
	<option value='https://gmepodcast.com/2007/11/'> November 2007 </option>
	<option value='https://gmepodcast.com/2007/10/'> October 2007 </option>
	<option value='https://gmepodcast.com/2007/09/'> September 2007 </option>
	<option value='https://gmepodcast.com/2007/08/'> August 2007 </option>
	<option value='https://gmepodcast.com/2007/07/'> July 2007 </option>
	<option value='https://gmepodcast.com/2007/06/'> June 2007 </option>
	<option value='https://gmepodcast.com/2007/05/'> May 2007 </option>
	<option value='https://gmepodcast.com/2007/04/'> April 2007 </option>
	<option value='https://gmepodcast.com/2007/03/'> March 2007 </option>
	<option value='https://gmepodcast.com/2007/02/'> February 2007 </option>
	<option value='https://gmepodcast.com/2007/01/'> January 2007 </option>
	<option value='https://gmepodcast.com/2006/12/'> December 2006 </option>
	<option value='https://gmepodcast.com/2006/11/'> November 2006 </option>
	<option value='https://gmepodcast.com/2006/10/'> October 2006 </option>
	<option value='https://gmepodcast.com/2006/09/'> September 2006 </option>
	<option value='https://gmepodcast.com/2006/08/'> August 2006 </option>
	<option value='https://gmepodcast.com/2006/07/'> July 2006 </option>
	<option value='https://gmepodcast.com/2006/06/'> June 2006 </option>
	<option value='https://gmepodcast.com/2006/05/'> May 2006 </option>

		</select>
		</li>
<li id="blog-stats-2" class="widget widget_blog-stats"><h2 class="widgettitle">Blog Stats</h2>
		<ul>
			<li>1,672,835 hits</li>
		</ul>
		</li>
<li id="image-3" class="widget widget_image"><h2 class="widgettitle">Buy my Book!</h2>
<div style="overflow:hidden;"><a href="http://www.amazon.com/Dragon-Kicker-XV-Paul-Chapman-ebook/dp/B00G04RUBM/"><img src="https://siliconchickens.files.wordpress.com/2013/12/dk_tiny.jpg?w=130&amp;h=206" class="alignnone" width="130" height="206" /></a></div>
</li>
<li id="image-4" class="widget widget_image"><h2 class="widgettitle">Friends&#8217; Work:</h2>
<div style="overflow:hidden;"><a href="http://www.amazon.com/gp/product/B007BDINQ2/"><img src="https://gooberzilla.files.wordpress.com/2013/01/lincoln_division_tiny.jpg?w=114&amp;h=160" alt="The Lincoln Division by Carl Boehm" class="alignnone" width="114" height="160" /></a></div>
</li>
<li id="image-5" class="widget widget_image"><h2 class="widgettitle">Friends&#8217; Work:</h2>
<div style="overflow:hidden;"><a href="http://www.destroyallcomics.com/shop/"><img src="https://gooberzilla.files.wordpress.com/2013/01/ggrcoversell_tiny.png?w=145&amp;h=214" alt="Golden Gate Riot by Jeremy Kaufmann &amp; Jeik Dion " class="alignnone" width="145" height="214" /></a></div>
</li>
<li id="image-7" class="widget widget_image"><h2 class="widgettitle">Friends&#8217; Work:</h2>
<div style="overflow:hidden;"><a href="http://rachelpandich.com/buy-stuff/"><img src="https://gooberzilla.files.wordpress.com/2013/02/aspire_tiny.jpg?w=95&amp;h=150" class="alignnone" width="95" height="150" /></a></div>
</li>
<li id="image-6" class="widget widget_image"><h2 class="widgettitle">Otaku USA:</h2>
<div style="overflow:hidden;"><a href="http://www.otakuusamagazine.com"><img src="https://gooberzilla.files.wordpress.com/2013/01/otaku_banner-e1359228588729.png?w=117&amp;h=50" class="alignnone" width="117" height="50" /></a></div>
</li>

</ul>
	</div>
</div><!-- End pagewrapper -->

<div id="footer">
<p><a href="https://wordpress.com/?ref=footer_website">Create a free website or blog at WordPress.com.</a> WP Designer.</p>
</div>

</div><!-- end page -->

</div><!-- End container id -->

<!--  -->
<script type='text/javascript' src='//0.gravatar.com/js/gprofiles.js?ver=201719y'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/gravatar-hovercards/wpgroho.js?m=1380573781h'></script>

	<script>
		//initialize and attach hovercards to all gravatars
		jQuery( document ).ready( function( $ ) {

			if (typeof Gravatar === "undefined"){
				return;
			}

			if ( typeof Gravatar.init !== "function" ) {
				return;
			}			

			Gravatar.profile_cb = function( hash, id ) {
				WPGroHo.syncProfileData( hash, id );
			};
			Gravatar.my_hash = WPGroHo.my_hash;
			Gravatar.init( 'body', '#wp-admin-bar-my-account' );
		});
	</script>

		<div style="display:none">
	</div>
<script type='text/javascript'>
/* <![CDATA[ */
var HighlanderComments = {"loggingInText":"Logging In\u2026","submittingText":"Posting Comment\u2026","postCommentText":"Post Comment","connectingToText":"Connecting to %s","commentingAsText":"%1$s: You are commenting using your %2$s account.","logoutText":"Log Out","loginText":"Log In","connectURL":"https:\/\/gooberzilla.wordpress.com\/public.api\/connect\/?action=request","logoutURL":"https:\/\/gooberzilla.wordpress.com\/wp-login.php?action=logout&_wpnonce=e08ff6dd9d","homeURL":"https:\/\/gmepodcast.com\/","postID":"2679","gravDefault":"identicon","enterACommentError":"Please enter a comment","enterEmailError":"Please enter your email address here","invalidEmailError":"Invalid email address","enterAuthorError":"Please enter your name here","gravatarFromEmail":"This picture will show whenever you leave a comment. Click to customize it.","logInToExternalAccount":"Log in to use details from one of these accounts.","change":"Change","changeAccount":"Change Account","comment_registration":"","userIsLoggedIn":"","isJetpack":"0","text_direction":"ltr"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??/wp-content/js/jquery/jquery.autoresize.js,/wp-content/mu-plugins/highlander-comments/script.js?m=1479964158j'></script>

	<div id="carousel-reblog-box">
		<form action="#" name="carousel-reblog">
			<textarea id="carousel-reblog-content" name="carousel-reblog-content" placeholder="Add your thoughts here... (optional)"></textarea>
			<label for="carousel-reblog-to-blog-id" id="carousel-reblog-lblogid">Post to</label>
			<select name="carousel-reblog-to-blog-id" id="carousel-reblog-to-blog-id">
						</select>

			<div class="submit">
				<span class="canceltext"><a href="#" class="cancel">Cancel</a></span>
				<input type="submit" name="carousel-reblog-submit" class="button" id="carousel-reblog-submit" value="Reblog Post" />
				<input type="hidden" id="carousel-reblog-blog-id" value="736319" />
				<input type="hidden" id="carousel-reblog-blog-url" value="https://gmepodcast.com" />
				<input type="hidden" id="carousel-reblog-blog-title" value="The Greatest Movie EVER! Podcast" />
				<input type="hidden" id="carousel-reblog-post-url" value="" />
				<input type="hidden" id="carousel-reblog-post-title" value="" />
			</div>

			<input type="hidden" id="_wpnonce" name="_wpnonce" value="7e84e2f42e" /><input type="hidden" name="_wp_http_referer" value="/2017/05/07/droppin-bombs-with-m-o-m/" />		</form>

		<div class="arrow"></div>
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/gmepodcast.com\/2017\/05\/07\/droppin-bombs-with-m-o-m\/":2679};
	</script>
		<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-facebook' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
		});
		</script>
				<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-linkedin' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
		});
		</script>
				<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-twitter' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
		});
		</script>
		<script type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/akismet-3.0/_inc/form.js?m=1404442431h'></script>
<link rel='stylesheet' id='all-css-0-3' href='https://s1.wp.com/wp-content/mu-plugins/carousel/jetpack-carousel.css?m=1481571546h' type='text/css' media='all' />
<!--[if lte IE 8]>
<link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='https://s1.wp.com/wp-content/mu-plugins/carousel/jetpack-carousel-ie8fix.css?m=1412618825h&#038;ver=20121024' type='text/css' media='all' />
<![endif]-->
<script type='text/javascript'>
/* <![CDATA[ */
var jpfbembed = {"appid":"249643311490","locale":"en_US"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var actionbardata = {"siteID":"736319","siteName":"The Greatest Movie EVER! Podcast","siteURL":"https:\/\/gmepodcast.com","icon":"<img alt='' src='https:\/\/secure.gravatar.com\/blavatar\/b540782203e9bb277d4207695c34f1f1?s=50&d=https%3A%2F%2Fs1.wp.com%2Fi%2Flogo%2Fwpcom-gray-white.png' class='avatar avatar-50' height='50' width='50' \/>","canManageOptions":"","canCustomizeSite":"","isFollowing":"","themeSlug":"pub\/digg3","signupURL":"https:\/\/wordpress.com\/start\/","loginURL":"https:\/\/gooberzilla.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Fgmepodcast.com%2F2017%2F05%2F07%2Fdroppin-bombs-with-m-o-m%2F","themeURL":"","xhrURL":"https:\/\/gmepodcast.com\/wp-admin\/admin-ajax.php","nonce":"485e562343","isSingular":"1","isFolded":"","isLoggedIn":"","isMobile":"","subscribeNonce":"<input type=\"hidden\" id=\"_wpnonce\" name=\"_wpnonce\" value=\"e6db22e23a\" \/>","referer":"https:\/\/gmepodcast.com\/2017\/05\/07\/droppin-bombs-with-m-o-m\/","canFollow":"1","statusMessage":"","customizeLink":"https:\/\/gooberzilla.wordpress.com\/wp-admin\/customize.php?url=https%3A%2F%2Fgooberzilla.wordpress.com%2F2017%2F05%2F07%2Fdroppin-bombs-with-m-o-m%2F","postID":"2679","shortlink":"http:\/\/wp.me\/p35y7-Hd","canEditPost":"","editLink":"https:\/\/wordpress.com\/post\/gmepodcast.com\/2679","statsLink":"https:\/\/wordpress.com\/stats\/post\/2679\/gmepodcast.com","i18n":{"view":"View site","follow":"Follow","following":"Following","edit":"Edit","login":"Log in","signup":"Sign up","customize":"Customize","report":"Report this content","themeInfo":"Get theme: Digg 3 Column","shortlink":"Copy shortlink","copied":"Copied","followedText":"New posts from this site will now appear in your <a href=\"https:\/\/wordpress.com\/\">Reader<\/a>","foldBar":"Collapse this bar","unfoldBar":"Expand this bar","editSubs":"Manage subscriptions","viewReader":"View site in the Reader","subscribe":"Sign me up","enterEmail":"Enter your email address","followers":"Join 288 other followers","alreadyUser":"Already have a WordPress.com account? <a href=\"https:\/\/gooberzilla.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Fgmepodcast.com%2F2017%2F05%2F07%2Fdroppin-bombs-with-m-o-m%2F\">Log in now.<\/a>","stats":"Stats"}};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/gmepodcast.com\/wp-admin\/admin-ajax.php","nonce":"d288e5867a","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/gooberzilla.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Fgmepodcast.com%2F2017%2F05%2F07%2Fdroppin-bombs-with-m-o-m%2F","blog_id":"736319","local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>","reblog":"Reblog","reblogged":"Reblogged","reblog_add_thoughts":"Add your thoughts here... (optional)","reblogging":"Reblogging...","post_reblog":"Post Reblog","stats_query_args":"blog=736319&v=wpcom&tz=0&user_id=0&subd=gooberzilla","is_public":"1","reblog_enabled":""};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s0.wp.com/_static/??-eJx9T8tuAjEM/KEGA6qoeqj6KZU3MeBs4qR2Qtu/J0hdxAHtydZ4Hh74qc4XaSQNokGgC3uqv5toL/Bwyt3V1E8sBolnMvju1OmMEhLpCjlSq+hn+GLxcERPUymzozxRWFFhyCxuQoWM1kjH5sqFVDmM6Du25uAbF7k53LeFPT5J/eYz6lpleYbHUU///sfmkfUky6OWbpSWsm4BVjS1WHPHhKxgZ1SW0zKH6DN/7F7f99vtYbd/i1cmV5xJ'></script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script>	<script type="text/javascript">
	var skimlinks_pub_id = "725X584219"
	var skimlinks_sitename = "gooberzilla.wordpress.com";
	</script>
	<script type="text/javascript" defer src="https://s.skimresources.com/js/725X1342.skimlinks.js"></script>		<iframe src='https://widgets.wp.com/likes/master.html?ver=20170206#ver=20170206' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
		<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
		<script>
			var _comscore = _comscore || [];
			_comscore.push({
				c1: "2",
				c2: "7518284"
			});
			(function() {
				var s = document.createElement("script"),
					el = document.getElementsByTagName("script")[0];
				s.defer = true;
				s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
				el.parentNode.insertBefore(s, el);
			})();
		</script>
		<noscript>
			<p class="robots-nocontent"><img src="https://sb.scorecardresearch.com/p?c1=2&c2=7518284&c3=&c4=&c5=&c6=&c15=&cv=2.0&cj=1" alt="" style="display:none;" width="1" height="1" /></p>
		</noscript><script src="//stats.wp.com/w.js?56" type="text/javascript" async defer></script>
<script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'736319','blog_tz':'0','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'736319','v':'wpcom','tz':'0','user_id':'0','post':'2679','subd':'gooberzilla'}]);
_stq.push(['extra', {'crypt':'UE5XaGUuOTlwaD85flAmcm1mcmZsaDhkV11YdWtpP0NsWnVkPS9sL0ViLndld3BuVT01Unp2dX5PUHVVd01oflVCT0IlXzdwaC1sM0J+QyxUNGw4ODVGSkNMbC4sNGtlfGUmQkhVaH5ERGhfQ25+WHJMZHwtXXpiQmNlWmJnd0tdc0lRdGdfSG9jSD1lQjE2SUlyOWRnTDk4WmNJVE0vVi0uenw5aldrMHQrU2lUcWw9eVJEND91aDksQ2k0ZTN0Q3VjVzYmbVNzeW9iRVFhSjV8c294T2RdZG9pR0N4fnBPOUo/TlsuTFJSQ2Q1TGI/WHlreEZ8WFdiLHQlUT9wWDdnZj9wPU94RnxqZmsmUG0uZl02fGkyQk5LUUlSdWVMVnB2VXhmbE5ELFd8QmtsNw=='}]);
_stq.push([ 'clickTrackerInit', '736319', '2679' ]);
	</script>
<noscript><img src="https://pixel.wp.com/b.gif?v=noscript" style="height:0px;width:0px;overflow:hidden" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script>
</body>
</html>
